bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: schan-user: apcupsd fährt Arktur runter, rebootet dann aber wieder!

To: <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: schan-user: apcupsd fährt Arktur runter, rebootet dann aber wieder!
From: "Wolfgang Becker" <wobe@xxxxxxxxxxxxx>
Date: Mon, 21 Jan 2002 23:28:55 +0100
Hallo,
Helmut Hullen schrieb:
> Ich habe mir mal die Versionen angeschaut: auf Anhieb bin ich skeptisch.
> Ist vor allem für "RedHat" geschrieben.

In "apcupsd-3.3.0.bin.linux.tar.gz" die ich von APC herunterlud, scheint es in 
der INSTALL-Datei
einen Schalter für Slackware zu geben.

Reiner Klaproth schrieb:
>
> Also in diesem Fall auf V3.3 umsteigen...
>
Das werde ich tun. Gerade läuft der Download mit 85,8 KB/Sek

> Was dazu kommt: Arktur V3.3 schaltet Rechner mit ATX-Netzteilen wirk-
> lich aus.

Aber isch abe gar kein ATX-Netzteil ;-)

> Der APC-Daemon schaltet auch die USV aus, aber nur, wenn die
> wirklich vom Strom getrennt ist!
>
Das ist klar, nur tut er das (im Falle der BackUPS 350 z.B.) erst nach den
festeingestellten 90 Sekunden. Und mein Arktur fängt in eben dieser Zeit wieder 
an
zu booten.
Bei der Ursachenforschung habe ich mich vollständig in den verschiedenen 
Scripts und
Daemonen verheddert.
Geht das so?
in /etc/initab: pf, pn, ps für powerfail start, now, stop
in /sbin/powerfail: ARG=now -> shutdown -f -h +1 "Shutting down the System"
oder so?
apcupsd  -> /sbin/powersc $1=REMOTE -> $SCHUTDOWN -h now
oder so?
apcupsd -> /sbin/init.d/halt $0=halt, dann /sbin/powersc KILL
??
und warum dennoch reboot?
Keine Ahnung.

 Viele Grüße,
       Wolfgang

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 22.01.2002