bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] keine Useranmeldung bei Linux-Clients an Arktur 3.6

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] keine Useranmeldung bei Linux-Clients an Arktur 3.6
From: Rudolf Lucas <rudolf.lucas@xxxxxx>
Date: Sun, 16 Dec 2007 17:38:44 +0100
Hallo Ernst,

Ich hatte eine ähnlichen Effekt. Nachdem ich in der /etc/passwd in der
letzte Zeile um die Shell ergänzt hatte, funktionierte es. In der
/etc/passwd von Arktur ist eine andere Shell angegeben ( nämlich
/usr/lib/ods-server/shells/passarktur), die auf dem Linux-Client nicht
vorhanden ist. Daher die Weigerung vom XWindows.

/etc/passwd
.
.
:::::/bin/bash

Das habe ich nicht genau verstanden.
Du hast in der /etc/passwd in der letzten Zeile etwas geändert oder am Ende bei jedem Benutzereintrag?

Außerdem: hast du damit nicht jedem Benutzer die Shell freigegeben? Da wäre ich skeptisch ohne aber genau zu wissen, welche Lücken man damit aufreißt.

Ich hatte mir schon so etwas gedacht, dass das mit der /etc/passwd zusammenhängen könnte, denn die Normaluser werden bei Arktur 3.6 nicht mehr wie bei der 3.5 an die "Pseudoshell" /usr/bin/passwd gebunden, sondern an /usr/lib/ods-server/shells/passarktur.

Das erstere ist eine Binärdatei zum Ändern des Passworts und das zweitere ist ein Script.

Du musst mir nur nochmal genau beschreiben, was du geändert hast.

Gruß, Rudolf


_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 16.12.2007