bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Drucken mit Printservern hakt

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Drucken mit Printservern hakt
From: Martin Hülsmann <huelsmann@xxxxxxxxxxxxx>
Date: Mon, 09 Jan 2012 21:15:01 +0100
Hallo Jürgen,

Am 09.01.2012 17:06, schrieb Juergen Engeland:
Hallo Martin,

doppelte IP-Adressen sind zunächst einmal die nahe liegende Erklärung.
Genaueres als Anmerkungen im Text.

Gruß Jürgen


Am 09.01.2012 15:21, schrieb Martin Hülsmann:
Hallo Liste(n),

folgendes Problem zeigt sich seit einigen Wochen:

Wir haben je Klassenraum einen Drucker, der per Printserver ans Netz
angebunden ist und auf den Clients "lokal" (wie man das eben so macht)
eingerichtet ist. Das hat lange Zeit auch so hervorragend
funktioniert. Neuerdings klappt das Drucken nicht mehr. Teils kommt
der Druckauftrag sofort an (eher selten), manchmal erst nach einer
Stunde, da hat der Spooler im Client schon längst aufgegeben. Die
Printserver lassen sich auch nur manchmal und nur zum Teil anpingen.
Ein Reset am Printserver kann helfen, aber nur kurze Zeit.
Passt ...


Das Ganze hängt hinter einem Arktur 5.3 in einem Netz 192.168.3.x, die
Printserver haben fest eingestellte IP-Adressen.

Wir verwenden Longshine LCS-PS-101-2 und bei den alten HP-Druckern den
HPJetDirect. Zuerst dachte ich, ein Printserver wäre defekt, aber ein
Austausch hat das Problem nicht beseitigt.

Ist es denkbar, dass irgendwas im Netz herumschwirrt, das die Drucker
am Drucken hindert? Gibt es Sniffing-Tools, die mir vielleicht helfen,
dem auf die Spur zu kommen?
Ich erinnere mich noch an den Fall, dass im Netzwerk eines großen
Flugzeugherstellers "nichts mehr ging".
Keiner wollte mir glauben, als ich als externer Dienstleister nach 10
Minuten den Verdacht äußerte, es gäbe einen zweiten DHCP-Server im Netzwerk.
- bis der Werksschutz nach zwei Stunden einen PC fröhlich mit einer
Linux-Live-CD vor sich hin werkeln fand.
Das ganze war insofern noch weniger schlimm, weil dieser völlig andere
Adressen als die dort verwendeten vergab.

Herausgefunden hatte ich das mit "ipconfig /all", "ping" und "arp -a".
Damit siehst Du, welche MAC-Adressen mitspielen.

Das wären dann die tests, die ich machen müsste

Wegen dieser Geschichte ist bei "meinen" Schulrechnern das Booten von CD
im (passwortgeschützten!) BIOS ausgeschaltet, wo es geht (Geht leider
nicht immer).

Doppelte IP-Adressen wären eine Möglichkeit, aber nicht bei allen
Druckern gleichzeitig, und dann wäre das Problem auch nicht plötzlich
im gesamten Netz aufgetreten.
Warum nicht?
Sollten sich alle Deine feste IP-Adressen innerhalb des DHCP-Scope
befinden, so kann der DHCP-Server jede davon doppelt vergeben.
Wenn Du so ein Pärchen hast, kann es in dem Moment, wo beide aktiv sind
(lease eines PC seit  dem Ausschalten noch nicht abgelaufen) richtig
Stress auf dem Netz geben.

Ich weiß nicht, ob ein Printserver "schlau" genug ist, sich schlafen zu
legen, wenn es seine IP-Adresse beim Einschalten schon im Netz gibt, wie
es ein Windows-Rechner macht.

Übrigens reicht es bei DHCP soweit ich weiß nicht, eine IP-Adresse
statisch einzutragen, um zu verhindern, dass diese noch einmal vergeben
wird. der Bereich für statische Adressen darf sich einfach nicht mit dem
Scope überschneiden!
Gilt zumindest für Windows Server und HP-UX ...

Win-Server sind bei mir nicht mit im Spiel. der (hoffentlich) einzige dhcp-Server ist Arktur.

Was aber tatsächlich sein kann, dass der mir da Probleme macht, denn die IPs der Printserver sind in der dhcp.conf nicht ausdrücklich ausgeschlossen. Das werde ich dann umgehend mal tun, dann dhcp stoppen, die lease-Datei löschen und anschließend dhcp neu starten. Wenn das Problem dann immer noch da ist, muss ich woanders weitersuchen.

Dass dhcp möglicherweise doch nicht danach schaut, ob eine Adresse schon manuell vergeben wurde, war mir nicht ganz klar, denn das Prozedere sieht doch vor, dass zunächst der Client anfragt, dann der Server eine Adresse anbietet, anschließend der Client anfordert und zum Schluss der Server bestätigt. Sollte der Client schon eine Adresse besitzen, meldet er sich doch mit dhcpinform beim Server. Oder ist das nur die Theorie?

Also: als erstes /etc/dhcpd.conf überprüfen!
Ich trage fest vergebene Adressen dort auch ein, wenn ich die Clients
nicht auf DHCP eingestellt habe.
So bin ich sicher, dass mir so etwas nicht passiert.

Werde ich dann erledigen.

Vielen Dank!

--
Viele Gruesse,

Martin Huelsmann

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 09.01.2012