bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] WIN 7 in Domäne an Arktur 4

To: 'Schulen ans Netz - Anwender' <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] WIN 7 in Domäne an Arktur 4
From: "Wilczak, Miroslaw" <Miroslaw.Wilczak@xxxxxxxxxxxx>
Date: Mon, 27 Feb 2012 18:51:26 +0000
Hallo Markus,

Noch eine Antwort:

Hallo Reiner,

danke, obwohl für mich das nicht nötig war.
Ich schrieb  ja folgendes:
> > Es ist mir auch gelungen
Es ist mir alles Gelungen! Dachte ich mir...
Ich muss aber  sagen, dass sich mich um %a nicht gekümmert habe, da ich fest 
die WinXP.bat in der smb.conf hatte.
Um Profile auch nicht, da ich nur lokale benutze.

Keiner hatte aber gefragt..., wie ich das gemacht hatte.
Es besteht kaum Interesse an der Lösung, war mein erster Gedanke.

Ich habe eine Testumgebung für neue Samba 3.3.10 geschaffen, zufällig muss ich 
auch zugeben, da ich sie mit nicht geänderten Zielordnern kompiliert hatte.
Sie landete in /usr/local/samba. Ich musste die Datei /etc/init.d/samba zum 
Start von neuem Samba anpassen. Einige Programmstellen habe ich am Anfang der 
Datei verändert, damit neue Samba startet. Es startete nur als ich die folgende 
Zeile:
export LD_LIBRARY_PATH=/usr/local/samba/lib
am Anfhang der /etc/init.d/samba geschrieben hatte.

Testparm wollte nicht starten, deshalb musste ich noch einmal an der Konsole 
den Befehl absetzten, damit eine neue Bibliothek  *.o.1 (den Namen kann ich 
mich nicht mehr erinnern)  gefunden wird.
Ich musste auch eine LDAP samba.schema im /etc/openldap/schema/ ersetzen.
Warum aber die Anmeldung erst klappte, als ich die 
/usr/local/samba/secrets/secrets.tdb mit der /etc/samba/private/secrets.tdb  
alten ersetzen musste, weiß ich nicht bis heute...
Die neue secrets.tdb ist größer als die alte.
Ich wollte nicht alle Skripte anpassen, dashalb habe ich alle Dateien aus 
/usr/local/samba/bin ins /usr/bin kopiert.
Die anderen aus /usr/local/samba/sbin (nmbd und smbd) sind dort geblieben und 
für sie habe ich nur die Path Variablen im Startskript angepasst.

Ich konnte neue User aufnähmen. Sie sind auch unter sysadm sichtbar und ich 
konnte mich mit den neuen Usern in die Domäne anmelden.
Alles war Windows 7 Prof. 64 Bit Version.

Mein Testrechner ist unter Windows XP Prof (32 Bit) mit Wächterkarte (Realtek 
Netzwerk Version 4.2) ausgestattet.
Hier nach der Veränderungen und Anpassungen am Arktur konnte ich mich an der 
Domäne nur als der User adm anmelden.
Nur einmal klappte die Anmeldung als  Lehrer oder Schüler. Später nach dem 
neuem Start ohne Schutz der Wächterkarte nicht mehr.
In den Administratoren Gruppe und einigen anderen waren plötzlich neue User da 
und die Anmeldung an die Domäne endete mit einem Fehler.
Aus dem Microsoft Hilfedatenbank konnte ich erfahren, dass es um Rechte geht.  
Die Anmeldung an die Domäne hatte auch nicht geklappt als ich die Rechte 
angepasst hatte.

Der Rechner ist speziell folgend eingerichtet worden:
1. Der adm User wurde zu Default User.
        - sich als adm in der Domäne anmelden
        - adm user abmelden
        - als lokaler Administrator anmelden
        - in Explorer alle Dateien  anzeigen (auch geschützte)
        - der Gruppe Administratoren lokalen User Jeder zuweisen.
        - mit regedit nach  Profilelist suchen und den Default User dort finden.
        - Default User aus dem Registry entfernen - so sollte es sein.
Ich habe mich nicht getraut den letzten Punkt voll durchzuführen. Einmal, 
nachdem ich das gemacht hatte, es konnte sich keiner anmelden...
Ich hatte nur den Default User als Default User mit adm ersetzt.
(Unter dem Schlüssel DefaultUserProfile).


Viele  Grüße

Mirek
Bitte überlegen Sie, ob Sie diese Nachricht wirklich ausdrucken müssen.

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 27.02.2012