bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Internetzugriff ist langsam

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Internetzugriff ist langsam
From: Juergen Engeland <juergen.engeland@xxxxxxxxxxx>
Date: Fri, 04 May 2012 09:30:24 +0200
Am 03.05.2012 20:57, schrieb Klemens Gördes:
> Am 27.04.2012 20:49, schrieb Helmut Hullen:
>> Hallo, Klemens,
>>
>>
>> Sieht alles "in sich" gut aus.
>>
>> Experimentier doch mal mit den folgenden Varianten von "/etc/
>> resolv.conf":
>>
>> domain xx.yy.de
>> nameserver 127.0.0.1
>> nameserver 192.168.178.1
>> nameserver 8.8.8.8
>>
>> oder
>>
>> domain xx.yy.de
>> nameserver 127.0.0.1
>> nameserver 8.8.8.8
>> nameserver 192.168.178.1
>>
>> --------------
>>
>> Also nix mit dem 194.x.y.z-Nameserver, stattdessen den "Google"-
>> Nameserver.
>>
>> In beiden Fällen: danach
>>
>>   /etc/init.d/named stop
>>   /etc/init.d/named start
>>   squid -k reconfigure
>>
>>
>>
> Hallo Helmut,
>
> ich habe zwischenzeitig vieles probiert. Es bleibt der Verzögerung
> beim erstmaligen Aufruf einer URL. Auch ein "ping" auf eine URL
> erlaubt sich entsprechende Gedenksekunden. M.E. löst eine DNS-Anfrage
> an Arktur (localhost) keine Auflösung auf externen Servern (bzw. dem
> Router) aus. Erst nach einem Timeout wird der zweite Nameserver
> abgefragt und führt zum Erfolg. Versuche mit einem anderen forwarder
> in /etc/named.conf brachten auch keine Änderung . Nur wenn ich den
> Router als ersten Nameserver in /etc/resolv.conf eintrage läuft alles
> flüssig. Dann funktioniert aber die lokale Mailzustellung z.B. von
> cron nicht mehr.
Weil nur der DNS von Arktur die lokalen Adresse kennt.
Steht in /etc/hosts von Arktur eventuell Mist?
Ist die Reihenfolge dns hosts in nssswitch.conf so wie Du diese benötigst?
>
> Auch die Fehlermeldungen in /var/log/messages sind weiterhin vorhanden:
>
> May  2 15:01:00 Arktur named[4999]: DNS format error from
> 194.246.96.1#53 resolving a.tfag.de/A for client 192.168.0.1#54674:
> non-improving referral
> May  2 15:01:06 Arktur named[4999]: DNS format error from
> 194.246.96.1#53 resolving qs.ivwbox.de/A for client
> 192.168.0.1#54674:non-improving referral
D.h. Arktur hat eine DNS-Anfrage vom Client weitergeleitet, bekommt vom
Default Nameserver von T-Online zumindest keine korrekte Antwort ...
> May  2 15:01:07 Arktur named[4999]: success resolving
> 'www.l.google.com/A' (in '.'?) after disabling EDNS
> May  2 15:01:36 Arktur named[4999]: success resolving 'qs.ivwbox.de/A'
> (in 'ivwbox.de'?) after disabling EDNS
...  deaktiviert EDNS (was ist das?) und hat danach Erfolg.
Vielleicht hilft dies hier
http://www.linux-club.de/viewtopic.php?f=51&t=103043
>
> Viele Grüße Klemens
>
> _______________________________________________
> schan-user mailing list
> schan-user@xxxxxxxxxxxxxxxxx
> http://www.heise.de/bin/newsletter/listinfo/schan-user
>


_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 « Vorige im Thread  Dieser Thread  Nächste im Thread » 

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 04.05.2012