bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Eigene Dateien dauerhaft umbiegen

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Eigene Dateien dauerhaft umbiegen
From: Hans-Dietrich Kirmse <hd.kirmse@xxxxxx>
Date: Thu, 09 Aug 2012 17:16:24 +0200
Hallo Wolfgang,

Am 09.08.2012 13:29, schrieb Wolfgang See-Metz:

In der logon.bat mit dem Eintrag
"regedit /s Profile.reg" usw.
(nach Anleitung
http://arktur.de/Wiki/index.php?title=Client:Windows#Verfahren
- Vorschlag von Christoph Eberhardt).

Das klappte leider immer nur mit der jeweils 2. Anmeldung - also nach
der 1. Abmeldung

Das ist völlig richtig und auch logisch.
weil du die einträge in der Registry änderst - weiter nichts. Du löst
keine Aktion aus, die z.B. ein Verzeichnis anlegt oder gar irgendwelche
Dateien dann dahin kopiert. diesen Kopierprozess übernimmt
dankenswerterweise Windows, nämlich bei der Abmeldung, denn da wird ja
zurück auf den Server kopiert und windows schaut ja noch, wohin es
kopieren muss und nimmt demzufolge den Eintrag aus der Registry. Das
kann gar nicht anders sein.

Das zeigt sich mir aber anders.

gut, dann solltest du über poledit arbeiten.

Nach Auskunft hier in der Liste kann man den Ordner dauerhaft auf das
Netzlaufwerk setzen.

klar - geht problemlos.

Das funktioniert ja auch - nur eben erst beim 2.
Login. eine bei meinem Test-Client erstellte Datei erscheint sofort auf
den Server.

Hm, die erstellt Datei wird nicht kopiert, sondern durch dich erstellt und Windows sagt dann nur, wo die abgelegt wird. Steht ja in der Registry.

Da wird dann offensichtlich nur noch das Profil am Ende der
Sitzung zum Server kopiert.

ja, diese neu erstellte Datei wird ja nicht kopiert. Die Dateien die vorher da waren müssen aber noch kopiert werden. und diese Kopieraktion wird beim Abmelden erledigt.

Nochmal: die alten Dateien müssen in dieses neue Verzeichnis kopiert werden, die neuen Dateien werden gleich dort abgelegt. Hast du das bei deinen Beobachtungen unterschieden?

Aber ich kann immernoch keinen Grund sehen, dass sich da das Einspielen einer reg-Datei und die Nutzung von poledit unterscheidet. Beides macht das Gleiche: die Registry ändern und nichts anderes.

Besser schien mir das Anlegen einer ntconfig.pol zu sein.
Mit entsprechender ADM-Datei konnte ich die "Eigenen Dateien" sofort
umbiegen.

ich denke, du hast bei den Beobachtungen nicht genau genug unterschieden und beide Wege unterscheiden sich vom Ergebnis nicht.

das kann ich überhaupt nicht verstehen. Die Einträge der ntconfig.pol
werden ja erst nach der Abarbeitung der logon.bat in die Registry
eingespielt - hat damit also die höhere Priorität. Auch hier wird
keinerlei Kopieraktion etc. ausgelöst.

Tja, was soll ich dazu sagen? Mehrfach getestet - so zeigt es sich mir.

siehe oben.

Leider fehlten daraufhin alle Netzlaufwerke außer U:.

Dieses adm-File ist absoluter Standard und völlig korrekt und pfuscht ganz bestimmt nicht an den Netzlaufwerken rum. Stellt sich nur die Frage, hast du (nacheinander) noch weitere adm-Files benutzt?


Bei mir ging das mit der config.pol problemlos. Habe aber die Doku nicht
mehr. (war jahrelang auf dem Th. Bildungsserver)

Ich vermute, dass irgendein Fehler verhindert, dass net use... dann
richtig ausgeführt wird?

also die Anleitung im Wiki (siehe angegebenen Link) ist okay.
Aber was du gemacht hast - ???

Auf http://www.gruppenrichtlinien.de/ habe ich die Datei
Ordnerumleitung.adm gefunden. (s. Anhang)
Im wesentlichen bin ich nach folgender Anleitung gegangen:
http://www.linupedia.org/opensuse/Poledit

Habe den "System Policy Editor" geöffnet, o.g. ADM-Datei eingelesen und
unter "Default User" den Pfad für die "Eigenen Dateien" auf
"U:\Profile\WinXP\Eigene Dateien" gesetzt.

Das ganze dann unter ntconfig.pol gespeichert und nach
/etc/samba/scripts kopiert.

das ist okay.

Wenn du mal ein paar brauchbare Informationen bereitstellen würdest, um
deine Installation / Modifikation nachvollziehen zu können, dann könnten
dir hier sehr viele helfen (mich eingeschlossen).

Ja, wenn ich nur wüsste, welche Informationen brauchbar sind:

deine logon.bat  wäre gut, ebenso deine smb.conf

(Bitte per PM oder irgendwo ablegen, um die anderen nicht zu behelligen)

Standardinstallation aber:

wie schon gesagt, ich habe keinen Arktur (mehr)

IP 192.168.0.22 (Bremen)

uninteressant

DHCP usw. übernimmt der Router.

ist hier auch uninteressant bzw. sollte keine Rolle spielen.

Arktur nur als Dateiserver.
Aktiv sind vorerst lediglich:

apache
ftp
mysql
samba
sshd

Mein test-Client löscht bei Systemstart die Benutzerprofile,

wie machst du das?

die sich
noch auf dem lokalen System befinden, da hier beim Abmelden von der
Domäne immer etliche alte Profile auf den Server kopiert wurden, obwohl
sie immer erfolgreich übertragen wurden.

Nö, beim Abmelden wird das Profil des *aktuellen* Users zurückkopiert.
Trotzdem würde mich interessieren, wie du das löschen machst.

Das war's vermutlich im Wesentlichen.
Ach so:
Arktur 5.3.0.3

Wenn das hier relevant ist: die Arktur5-Leute werden sich schon zu Wort melden und helfen.

Viele Grüße
Hans-Dietrich

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 09.08.2012