bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Arktur 4 keine Domäne vorhanden

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Arktur 4 keine Domäne vorhanden
From: Hans-Dietrich Kirmse <hd.kirmse@xxxxxx>
Date: Mon, 05 Nov 2012 19:07:30 +0100
Hallo Robert,

Am 05.11.2012 17:36, schrieb Juergen Engeland:
Hallo Robert,

die Meldungen deuten für mich darauf hin, dass LDAP nicht läuft.

das es irgendwie mit dem LDAP zusammenhängt, sehe ich auch so. Allerdings vermute ich, dass der LDAP läuft. Ich sehe das Problem darin, dass die Anmeldung als LDAP-Admin nicht gelingt, und damit auch der connect von Samba zum LDAP scheitert.

Den braucht (nicht nur) Samba unbedingt.

am 04.11.2012 12:50 stand:

"smbclient -U% -L localhost = es werden alle Freigaben (samba.conf) gezeigt"

Die werden aber nur gezeigt, wenn der LDAP läuft (und Samba am LDAP hängt). Deswegen würde ich darauf tippen, dass der LDAP läuft und das Problem an anderer Stelle zu suchen ist. Es würde aber trotzdem nichts schaden, einfach mal den Status abzufragen.

  /etc/init.d/slapd status

sollte liefern:  slapd is running

Ansonsten oder auch zur Sicherheit einfach nochmal neu starten mit

    /etc/init.d/slapd stop
    /etc/init.d/slapd start



Am 05.11.2012 15:43, schrieb Robert Hoffner:

ich denke, der folgenden Fehlermeldung sollten wir nachgehen

15:03:21  lib/smbldap.c:smbldap.connect_system(977) failed to bind to
server ldap://localhost:389/with d="cn=admin,d=hrswrs-neuried,c=de"
Error: can't contact ldap server

hier steht m.E. mal etwas frei übersetzt: Samba kann keine Verbindung zum LDAP-Server herstellen.

Meine Bitte: schaue doch mal nach, ob die Datei /etc/pam_ldap.secret vorhanden ist und ob das Passwort darin noch lesbar ist (als root). Das ist das Passwort, mit dem die Verbindung zum LDAP hergestellt wird. Dieses Passwort verwendet auch Samba zum connecten. Es kann m.E. nichts schaden, wenn du das für Samba neu setzt mit

  smbpasswd -w <passwort_aus_der_pam_ldap.secret>

dann ein "/etc/init.d/samba restart" und vielleicht haben wir ja Glück und es geht vielleicht schon wieder. Man kann ja optimistisch sein ;)

Viele Grüße
Hans-Dietrich

PS: irgenwie gefällt mir dieser DN nicht: d="cn=admin,d=hrswrs-neuried,c=de" - könntest du mir deine smb.conf per PM zukommen lassen?

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 « Vorige im Thread  Dieser Thread  Nächste im Thread » 

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 05.11.2012