bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Arktur neu aufsetzen -> welche Dateien kann ich umziehe

To: "Schulen ans Netz - Anwender" <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Arktur neu aufsetzen -> welche Dateien kann ich umziehen?
From: "juergen.engeland@xxxxxxxxxxx" <juergen.engeland@xxxxxxxxxxx>
Date: Tue, 29 Jan 2013 19:00:09 +0100
Von: "andrea@xxxxxxxxxxxx" <andrea@xxxxxxxxxxxx>
An: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Betreff: Re: [Schan-user] Arktur neu aufsetzen -> welche Dateien kann
ich umziehen?
Datum: Tue, 29 Jan 2013 18:51:22 +0100

 Hallo Jürgen,

hurra - endlich kann ich wieder auf meinen 1&1-E-Mail-Account
zugreifen!
Das konnte ich seit heute Morgen ca. 8:30 Uhr nicht mehr ...
Deshalb habe ich auch seither keine Mails mehr zu dem Thema gelesen.

Dafür waren Daniela und ich heute nach Deiner Anleitung zu Gange:

[...]

> Sichern:
> 1) altes System mit der CD booten
> 2) externe Festplatte mounten, z. B. mit mount /dev/sdb1, sie ist
dann
> unter /media/sdb1 verfügbar
> 3) zu sichernde Partition mounten, z. B. mount /dev/sda1
> 4) cd /media/sda1
> 5) find . | cpio -ov >/media/sdb1/sda1.cpio

Haben wir alles gemacht, wobei wir sda1, sda3 und sda4 in jeweils
einem
separaten Archiv gesichert haben.
Dauer ca. 2 1/2 Stunden mit USB 2.

> Wiederherstellen:
> 1) neues System mit der CD booten
> 2) externe Festplatte mounten, z. B. mit mount /dev/sdb1, sie ist
dann
> unter /media/sdb1 verfügbar

Mounten musste man gar nicht mehr. Sobald man die Platte anschließt,
erkennt Knoppix sie und mountet sie automatisch.

> 3) Zielfestplatten beliebig(!) partitionieren und formatieren

Wir haben uns an den Partitionsgrößen der alten Platte orientiert,
wobei sda2 als swap partitioniert wurde und die anderen 3 als ext2.

> 3) wiederherzustellende Partition mounten, z. B. mount /dev/sda1
> 4) cd /media/sda1
> 5) cpio -idumv </media/sdb1/sda1.cpio

Ging deultich schneller, max 20 Minuten.

> (die Schalter sorgen für die richtige Verzeichnisstruktur und die
> richtigen Rechte - bei "tar" zumindest früher ein Problem)
> 6) vi /media/sda1/etc/fstab und die Partitionstabelle der unter 3)
> vorgenommenen Aufteilung anpassen.

sieht folgendermaßen aus:

/dev/sda1 / ext2 defaults,user_xattr 0 1
/dev/sda2 swap swap defaults,pri=10 0 0
/dev/sda3 /var ext2 usrquota,user_xattr 0 2
/dev/sda4 /home ext3 usrquota,user_xattr 0 3
LABEL=Var /var ext2 usrquota,user_xattr 0 2
LABEL=Home /home ext3 usrquota,user_xattr 0 3
proc /proc proc defaults 0 0
tmpfs /tmp tmpfs defaults,size=500m,noauto 0 0
shm /dev/shm tmpfs defaults
pts /dev/pts devpts defaults 0 0
sysfs /sys sysfs noauto 0 0
/dev/sdb1 /platte2 ext3 defaults 0 4
# Die wechselbaren Datentraeger
/dev/sr0 /cdrom iso9660 defaults,ro,user,noauto 0 0
/dev/fd0 /a auto defaults,rw,umask=000,user,noauto,noexec 0 0

Ich seh gerade, dass wir sda4 als ext3 partitioniert haben, statt wie
die
anderen als ext2.
Ist das ein Problem? Das ist sogar besser! Entscheidend ist, was Ihr
bei "mkfs -t * /dev/sd?" eingegeben habt.

Müssen wir sonst noch was anpassen? Ja. ext2 bzw. ext3 müssen ebenso
wie die devices /dev/sd? in der fstab stimmen.

> Boot-fähig machen:
> Das kann die Arktur-CD bei Arktur am besten!

Haben wir gemacht, mit boot - System (wieder) startfähig machen,
Sollen die Daten e*r*h*a*l*t*e*n bleiben? <No>

Dann kommt folgende Meldung:
Lilo sagt:
Warning: Unable to determine video adapter in use in the present
sytem.
Added 2.6.38.3-ODS
Fatal: Setup length exceeds 31 maximum: kernelö setup will overwrite
boot loader

(mit der Kamera fotografiert, weil die Meldung ruckzuck verschwunden
ist).
Ich meine mich zu erinnern, dass Helmut sagte, die Meldung könnte man
ignorieren
...

Die lilo.conf sieht folgendermaßen aus:

# MBR für den c't/ODS-Schulserver
boot = /dev/sda
lba32

bitmap=/boot/arktur64.bmp
read-only
prompt
delay = 80
# 8 Sekunden
timeout = 100
# 10 Sekunden
vga = 788
default = Schulserver

Image = /boot/2.6.38.3-ODS/bzImage
root = current
# alias = Schulserver
label = 2.6.38.3-ODS
# initrd = /boot/2.6.38.3-ODS/initrd.gz
#
Image = /boot/3.6.11-ODSbig/bzImage
root = current
alias = Schulserver
label = 3.6.11-ODSbig
# initrd = /boot/3.6.11-ODSbig/initrd.gz

Daniela und ich waren wirklich guten Mutes, haben den Rechner mit der
neu
bespielten Festplatte gebootet und es kommt die Meldung:
PXE-E16: Media test failure, check cable
PXE-M0F: Exiting Intel Boot Agent

No Boot Device found. Press any key to reboot the machine

Wenn ich mit Knoppix den PC boote, kann ich auf die Festplatte ohne
Probleme auf
alle Partitionen zugreifen.

Ich werd noch zum Hirsch! Wo liegt das Problem? Wahrscheinlich passt
/etc/fstab noch nicht zu Eurer Plattenaufteilung. Mit device-IDs
verträgt sich das von mir beschriebene Verfahren nicht so gut, weil
man die auf dem neuen System erst einmal herausfinden müsste.

Viele Grüße
Andrea
_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx [1]
http://www.heise.de/bin/newsletter/listinfo/schan-user [2]

Links:
------
[1] javascript:void(0)
[2]
?ctl=dereferer&amp;to=aHR0cDovL3d3dy5oZWlzZS5kZS9iaW4vbmV3c2xldHRlci9saXN0aW5mby9zY2hhbi11c2Vy
_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 « Vorige im Thread  Dieser Thread  Nächste im Thread » 

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 29.01.2013