bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Profile für XP und Win7 prof

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Profile für XP und Win7 prof
From: Martin Hülsmann <huelsmann@xxxxxxxxxxxxx>
Date: Fri, 08 Nov 2013 18:50:00 +0100
Hallo Hans-Dietrich,

vielen Dank für deine ausführlichen Hinweise!

Inzwischen hat Helmut das Problem gelöst, ich weiß aber nicht genau, wie.
Am 08.11.2013 18:22, schrieb Hans-Dietrich Kirmse:
Hallo Martin,

Am 08.11.2013 08:59, schrieb Martin Hülsmann:
Hallo Hans-Dietrich,

Ich habe noch einmal ein wenig herumprobiert, u. a. habe ich original
deine Einstellungen aus der Profile-Section der smb.conf probiert: Keine
Änderungen.

Mit der Samba-Einstellung

\\%L\Profile\%U\%a

bekomme ich beim Client beim Anmelden die Fehlermeldung "Profil nicht
gefunden" usw., und in der /var /log/warn steht:

Capella:/var/log # grep 22:20 warn
Nov 7 22:20:10 Capella smbd[5015]: [2013/11/07 22:20:10.114626, 0]
rpc_server/srv_pipe.c:500(pipe_schannel_auth_bind)
Nov 7 22:20:10 Capella smbd[5015]: pipe_schannel_auth_bind: Attempt to
bind using schannel without successful serverauth2

Stelle ich wieder um nach

\\%L\%U\ntprofile

dann ist alles in Ordnung, und wenn im jew. Benutzerverzeichnis keine
ntprofile vorhanden ist, dann wird sie beim Abmelden angelegt.

Was hat das zu bedeuten?

dir ist bewußt, ds ich keinen Arktur5 habe und aus Erfahrung nur Arktur4
kenne und das ich deshalb nur spekulieren kann.

Wenn   \\%L\%U\ntprofile   geht und sogar das Verzeichnis 'ntprofile'
angelegt wird, dann bedeutet das zumindest, dass der Mechanismus zum
automatischen Erstellen des Profilverzeichnisses funktioniert. Es wäre
zur Sicherheit noch gut, wenn auch ein Test (für einen neuen User) mit
\\%L\%U\ntprofile\%a  durchgeführt würde. Ich bin mir sehr sicher, das
das auch gehen würde. Zumindest gehe ich davon (im Weiteren) aus.

Das er außerhalb des Homeverzeichnisses nicht funktioniert, bedeutet,
dort gibt es Probleme. Wie gerade erklärt, gehe ich davon aus, dass der
Mechanismus geht und da würde ich weiter schlußfolgern, dass es dann
egal ist, ob du

   \\%L\Profile\%U\%a

oder

   \\%L\Profile\%U

verwendest. Will sagen, der Vorschlag von H.Hullen von 10.11 dürfte
nicht gehen. (eine Überprüfung wäre trotzdem hilfreich, da nur es nur
eine Vermutung ist).

Ich kann 2 mögliche Stolpersteine erkennen. Als Erstes:

In der von H.Hullen bereitgestellten "Profil.txt" gibt es nicht den Eintrag

         profile acls         = yes

Diese Zeile hatte ich nachgetragen (gestern abend) - ohne Erfolg

Dieser Eintrag ist aber gerade für (Zugriffs-)Probleme bei win2000- und
winXP-Clients geschaffen worden. Egal ob der das Problem löst oder
nicht, ich würde unbedingt empfehlen, diesen Eintrag zu übernehmen. Aber
vielleicht ist es das ja schon.

andernfalls könnte das Problem hier liegen:

<kopie>
  Capella:/home # ls -la | grep ofile
  dr-xr-xr-x   2 root         root           4096 Aug 20  2003 ntprofile/
  dr-xr-xr-x   2 root         root           4096 Aug 20  2003 profile/
  drwxrwxrwx 893 root         root          24576 Nov  6 17:16 Profile/
  Capella:/home #
<kopie>

Wenn ich das richtig verstehe, bedeutet das, es gibt ein Verzeichnis

    /home/profile

welches (vermutlich 2003?) bei der Installation erstellt wurde.
Außerdem gibt es ein Verzeichnis

   /home/Profile

welches vor wenigen Tagen bei der Umstellung der Profile-Verzeichnisse
erstellt wurde und zwar so, wie es in der smb.conf angegeben wurde:

<kopie>
    \\%L\Profile\%U\%a
<kopie>

Das diese 2 verschiedenen Verzeichnisse (für Windows beim
zurückschreiben) ein Problem darstellen könnten, hatte ich ja schon
angegeben. Allerdings war der von mir angegebene Test dazu suboptimal
(zu deutsch: Mist).

Um rauszufinden, ob dieser Fakt das Problem ist, hast du 2 Möglichkeiten:

1. du löschst als root einfach '/home/profile/', sodass es auf
'/home/Profile/' zugegriffen wird. Du hattest ja geschrieben, dass
'/home/profile/' sowieso leer ist. Also könnte es auch keine Probleme
geben (oder statt löschen einfach umbenennen in irgendwas ganz anderes)

2. du löschst als root einfach '/home/Profile/'. Es sollten ja eh noch
keine Daten drin sein, weil es ja sowieso noch nicht ging. Damit Samba
aber nun das vorhandene Verzeichnis '/home/profile/' nutzt, muss in der
smb.conf natürlich geändert werden auf

    \\%L\profile\%U\%a

oder

    \\%L\profile\%U

Ich bin mir sehr sicher: wenn die untere Variante geht, dann geht auch
die obere Variante (mit %a).

Auch das habe ich gestern abend getestet, auch wenn ich /home/profile beseitige und es nur noch /home/Profile gibt, hat es nicht funktioniert.


Hoffe, dass dir das weiter hilft.

Hat es - zumindest beim drüber-Nachdenken. Ich hoffe, dass ich den Auslöser für das Problem irgendwann noch herausbekomme und vielleicht sogar reproduzieren kann - das wäre dann mal eine Hilfe für andere u. U. betroffene Kollegen.

Aber (s. o.) es läuft!

Ich werde mich in den nächsten Tagen mal dranmachen, vielleicht das Problem zu reproduzieren.

Also, nochmals vielen, vielen Dank!


Viele Grüße
Hans-Dietrich

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

--
Viele Gruesse,

Martin Huelsmann

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/bin/newsletter/listinfo/schan-user

 « Vorige im Thread  Dieser Thread  Nächste im Thread » 

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 08.11.2013