bolug bonner linux user group
news about wissen files archive hilfe suchen  

 

archive :: SchAN-User

druckfassung

SchAN-User

Re: [Schan-user] Seltsames Verhalten nach Update auf 5.5.05

To: Schulen ans Netz - Anwender <schan-user@xxxxxxxxxxxxxxxxx>
Subject: Re: [Schan-user] Seltsames Verhalten nach Update auf 5.5.05
From: Tim Schäfer <timsg@xxxxxx>
Date: Wed, 7 Sep 2016 10:26:35 +0200
Hallo nochmal,

ich habe in den letzten Tagen mal über die sehr schönen Skripte "squidguard" ausgestellt, um dem Fehler auf die Schliche zu kommen, warum der Internet-Zugang von Windows 7 Rechnern gestört ist.

Es hat sich nicht viel geändert bisher, aber...

In der Physik wurde der Sammlungsrechner von Windows 7 auf Windows 10 umgestellt und nun läuft auch das Internet wieder... Meine zuerst lustig gemeinte Annahme scheint sich zu bewahrheiten, dass es etwas mit den Betriebssystemen zu tun hat...

Und trotzdem habe ich an einem Windows7-Rechner rausgefunden, dass seine IP-Adresse (192.168.0.20), die ihm per MAC-Adresse vorgegeben wird, in den dhcpd.leases an ein anderes Gerät vergeben wurde! Und zwar steht dort der Server als Eintrag. Diese Stelle verstehe ich nicht, denn ich vergebe nur wenige temporäre Adressen und die aus dem Bereich *.220-*.240.

Beim ping an 192.168.0.1 meldet sich brav Arktur. Wird arktur angepingt, meldet er sich auch!

Und der Rechner, der ursprünglich die *.20 hatte, bekam eine andere und funktioniert seitdem auch...


Warum ist eine feste IP-Adresse vergeben worden?

Kann ich die dhcpd.leases Datei zurücksetzen, den Inhalt einfach löschen?


Gruß, Tim


Am 29.08.2016 um 16:02 schrieb Tim Schäfer:

Interessant,

zu 1) das kann ich morgen abklären und die entsprechenden PC-Namen als sysadm ergänzen.

zu 2) das werde ich heute abend mal aus der Ferne anstoßen.

und 3) in meiner ssh_config sind nur kommentierte Zeilen. Da schaue ich heute abend auch einmal in einem Backup nach, ob das so war. Eine Zeile wie #HostKey /etc/ssh/ssh_host_ed25519_key steht bei mir aber nicht mal als Kommentar.

Danke für die Wege,

Gruß, Tim


Am 29.08.2016 um 14:15 schrieb Miroslaw Wilczak:
Hallo Tim,

Ich musste einige Anpassungen noch vornehmen.
In der Datei /etc/squid/squid.conf:

„# Abschnitt 7: Zugriffskontrolle
# --------------------------------

# SquidGuard benutzen
url_rewrite_program /usr/bin/squidGuard
### redirect_programm /usr/sbin/squidGuard -c /etc/squid/squidGuard.conf.in
redirect_children 20”

musste ich diese Zeile auskommentieren.

Es könnte die Fehlermeldung von der Zeile kommen, über die Du geschrieben hattest.

Die Datei /etc/squid/frei ist auch zu betrachten.


Viele Grüße
Mirek

Hallo Tim,


Zu 1.
Es könnte helfen, den Namen des PCs als sysadm einzufügen.
Unter /etc/squid sind Dateien die Squid steuern.
Sie erlaben oder blockieren das Surfen.
Bei mir laufen auch in einer Schule per Proxy Windows 7 PCs
ohne Anmeldung in der Domäne und ich hatte ähnliche Probleme
mit der Version 5.5.05. Nur hier war das kein Update sondern
Neuinstallation. Ich melde mich gleich wieder, wenn ich die
Schule erreiche…

Gleich sehe ich fern, was ich dort angepasst hatte

Zu 2.

Man sollte alle Daten unter /var/squid/cache löschen.
Bei mir sind das diese:
ls
“00/  01/  02/  03/  04/  05/  06/  07/  swap.state
swap.state.last-clean”

Z.B mit „mc“ und markieren der Daten und <F8> könntest Du die
Daten löschen.

Zu 3.
Keine Ahnung, wie man früher auf den Server fern zugreifen könnte?
Bei mir steht auch in der Datei /etc/ssh/sshd_config die
folgende Zeile:
#HostKey /etc/ssh/ssh_host_ed25519_key
Sie ist aber als Kommentar zu sehen.

Viele Grüße
Mirek






Hallo Mirek,

danke für die Tipps. Es ist noch etwas seltsamer: Ich habe
als "Good
Will" Aktion meinem Haupthausmeister einen neueren Rechner
mit Windows
10 aufgestellt. Jetzt gibt es tatsächlich keine Aussetzer
mehr an seinem
Rechner, aber beim zweiten Hausmeister ist immer noch alles
beim alten.
Sein Windows 7 Rechner bekommt häufig keinen Zugriff auf
das Internet
mit der Meldung: Proxy-Server verweigert die Verbindung!

Die weiteren Problemrechner sind übrigens auch alle noch Windows 7
Rechner!!! Ein scherzhafter Gedanke ist der Ersatz des gehassten
Win10-Werbe-GWX-Programms durch eine instabile Internetverbindung.
Mögliche Antwort eines MS-Hotline-Mitarbeiters: "Ach, Sie
nutzen noch
Windows7. Na dann..."

Zu deinen Tipps:

1) Wir haben keine Domänenanbindung (hatte ich vergessen zu
erwähnen).
Dann nützt ein Löschen des Nutzers nicht so viel, oder?

2) Wie lösche ich den Proxy korrekt? Mit" rm
var/proxy/cache/*", nachdem
ich den squid gestoppt habe? Das wäre ja auch eine
Möglichkeit, die mit
dem Update auf 5.5.05 zu tun haben könnte.

3) die vom System angefragte SSH-Datei habe ich ja auch
nicht und ich
verstehe nicht, welches Programm sie nun anfordert!

Zum Glück laufen ja die allermeisten Rechner...

Gruß, Tim


Am 29.08.2016 um 11:17 schrieb Wilczak, Miroslaw:
Hallo Tim,

ich würde als "sysadm" die Rechnernamen löschen und neu
einfügen, die Anmeldeprobleme haben.
An den fraglichen Rechner würde eventuell neue Einfügung in
die Schuldomäne "SC HULE" oder "WORKGROUP"  helfen können.
Du könntest auch den cache (var/proxy/cache/*) von squid
löschen, nachdem Du ihn gestoppt hast.
Dann kann es gestartet werden.
Zu 2.
Es gibt bei mir keine solche Datei, nur diese:
"moduli
ssh_host_dsa_key.pub
ssh_host_key
   ssh_host_rsa_
key.pub
ssh_config
   ssh_host_ecdsa_key
ssh_host_key.pub
sshd_config
ssh_host_dsa_key
ssh_host_ecdsa_key.pub
   ssh_host_rsa_key"

Lösche sie bitte (/etc/ssh/ssh_host_ed25519_key), oder
warte bis Helmut dazu etwas sagt.
Viele Grüße
Mirek



Guten Morgen,

nach einem Update von 5.5.01 auf 5.5.05 zeigt sich ein
seltsames Verhalten im Schulnetz:
1) Einige (wenige) Rechner haben nur temporären Zugriff auf
das Netz.
Oft wird ihnen der Zugriff verweigert und es handelt sich
bei diesen Rechnern auch noch um die der Hausmeister... Mit
denen darf man es sich ja nicht verscherzen. Komischerweise
haben Rechner, an denen ich arbeite, keine Ausfälle... Hier
werde ich gleich mal einen anderen Rechner aufstellen, um
Probleme mit dem Rechner an sich abzugrenzen.
Könnte der Eintrag in der warn-Datei "[squid]: starting new
redirector helpers..." damit zusammen hängen? Seit dem Update
werden auch einige Seiten (z.B. vimeo.com) nicht mehr
geladen. Hier erscheint nach einigen Sekunden, dass es einen
Umleitungsfehler gegeben hat.

2) Der SSH-Dämon meldet einen Fehler: error: Could not load
host key:
/etc/ssh/ssh_host_ed25519_key


Kann jemand helfen, an welchen Stellen ich schauen kann,
damit die Fehler verschwinden?

Danke im Voraus und Gruß aus Stadthagen, Tim Schäfer


_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/ct/schan

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/ct/schan

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/ct/schan

_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/ct/schan


_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/ct/schan


_______________________________________________
schan-user mailing list
schan-user@xxxxxxxxxxxxxxxxx
http://www.heise.de/ct/schan

 « Vorige im Thread  Dieser Thread  Nächste im Thread » 
  • Re: [Schan-user] Seltsames Verhalten nach Update auf 5.5.05, Tim Schäfer <=

 

seitenanfang


 

news about wissen files archive hilfe suchen  
kontakt letzte änderung: 07.09.2016